Autor Wątek: Brak pomysłów na nazwy zmiennych  (Przeczytany 10234 razy)

Vipa

  • Gość
# Sierpień 13, 2008, 15:58:25
Wiekszosc zarzutow odnosnie notacji wegierskiej bierze sie z niezrozumienia jej oryginalnych zasad. Prefiksy nie mialy oznaczac typow "niskopoziomowych" (bajt, word itd), a raczej zastosowanie.
Nie, większość zarzutów bierze się z tego że MS zawalił sprawę i źle użył notacji w WinAPI (lpcstrMessage). A dalej już poszło lawinowo.

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline snakeo

  • Użytkownik

# Sierpień 13, 2008, 16:28:36
no co long pointer to constant string ;p nie jest tak źle ;p

Offline Xion

  • Moderator
    • xion.log

# Sierpień 13, 2008, 17:30:05
Notacja węgierska dobrze nadaje się do nazywania elementów UI, dzięki czemu po nazwie widać, czy to przycisk, element, menu, checkbox, itd. Ma ona też o tyle więcej sensu, że w UI często jest tak, że kilka kontrolek nazywa się właściwie tak samo i różnią się tylko typem (np. TextBox i odpowiadający mu Label, który go opisuje).

Offline ajur

  • Użytkownik

# Sierpień 13, 2008, 18:33:12
Stroustrup o nazwach:
http://www.research.att.com/~bs/bs_faq2.html#Hungarian
Sam się zacząłem do jego uwag stosować i przyznam, że daje to wymierne skutki.

Offline LukiX93

  • Użytkownik

# Sierpień 20, 2008, 12:20:43
hmm jeżeli zmienne są tymczasowe, to popieram literki.

(Po coś nazywa się tą zmienną w pętlach "i"... ;D)

Offline Yarek

  • Użytkownik

# Sierpień 20, 2008, 12:39:35
heh, ja raz po zajrzeniu przez ramie do kodu koledze z biurka obok ujrzałem takiego potworka (nazwa metody): noToWioJGP
Spytany skąd taka wspaniała nazwa: "już k.. nie miałem pomysłu jak to nazwać"  ;D
A co do dodawania przedrostków dla elementów GUI jestem za i nawet się sprawdza. Pozwala to szybciej wyszukać dany element bez pamiętania jego nazwy czy szukania gdzieś w oknach obok.

Vipa

  • Gość
# Sierpień 30, 2008, 00:58:53
Może lekki off ale co mi tam :P

Ja ostatnie w robocie usłyszałem już znane zdanie:
" Maciej klinetowi nie działa program xyz, masz loga ściągnij z SourceSafe'a najnowsza wersja i obczaj co jest nie tak ".
 Na co ja jak zwykle zawijam rękawy i do roboty ...

Przedzierając się przez kolejne dialogi, przez kolejne wiersze kodu trafiam na źródło bólu ... HUra !!! Dziwne wartości zmiennych podczas inicjalizacji obiektu!!! ( ktoś zapomniał i zaczął używać zmiennych bez uprzedniej inicjalizacji co dało w pewnych przypadkach niepożądane efekty [ nvm ])

Nic w tym w sumie dziwnego gdyby nie to że dialog którego to dotyczyło miał identyfikator ( przpraszam za to :P ) IDD_CH**_WIE_PO_CO_TO

I jak tu człowieku się dostosuj do stylu panującego w firmie?

Offline pawelek

  • Użytkownik

# Styczeń 21, 2009, 00:55:31
pełny OFF-TOP i do tego po czasie, ale co mi tam :)

W pewnej firmie (programowanie w Delphi) prawie każdy napisany komponent posiadał parametr dupa... O dziwo nie raz bardzo użyteczny.

Offline Reg

  • Administrator
    • Adam Sawicki - Home Page

# Styczeń 21, 2009, 21:46:40
To apropos, przypomniało mi się że nieraz trzeba zdefiniować zmienną, której wcale nie mam zamiaru używać - na przykład żeby odebrać parametr wyjściowy BytesWritten funkcji WriteFile. Dawniej nazywałem go Dupa, obecnie najczęściej Foo :)

Vipa

  • Gość
# Styczeń 21, 2009, 23:02:14
Ja używam w takim przypadku: zmienna_raz_odczytująca_parametr_wejściowy :D.

Offline htmlowiecii

  • Użytkownik

# Maj 02, 2009, 10:50:51
a ja ide po kolei z abecadłem i na ogół przed k kończe

Offline Oester

  • Użytkownik

# Maj 02, 2009, 13:28:10
Pozdrawiamy archeologów.

A tak swoją drogą to faktycznie, zmienna o nazwie np. d bardzo dużo mówi o swojej funkcji.

Offline Haxy.M

  • Użytkownik

# Maj 02, 2009, 14:13:53
Jak już temat żyje.
Zwykłem był liczniki określać i,j,k,l,..., a zmienne tymczasowe na ogół temp, temp2, temp3. Wiem, ze to mało przejzyście, później tworzą się kwiatki
  for(;(i < num) && (i < size);++i,++temp2,++temp3)
  {
   (*temp2) = (*temp3);
  }

Ale i tak najlepsze co widziałem to komunikat o błędzie następującej treści "No i dupa!", problem w tym, że program był dla Portugalczyków, no i kiedyśtam wyskoczył im ten błąd. :P

Offline Reg

  • Administrator
    • Adam Sawicki - Home Page

# Maj 06, 2009, 21:06:18
A ja, chociaż jestem w tej sprawie chyba odosobniony, nie znoszę robić pętli po i, w niej pętli po j itd. Jeśli przechodzę np. po obiektach i w każdym z nich po wierzchołkach, to odpowiednie liczniki czy iteratory wolę nazwać np. obj_i, vertex_i. Wtedy trudniej się pomylić, niż posługując się i, j.

Offline _OskaR

  • Użytkownik

# Maj 06, 2009, 21:16:46
Dopóki program nie jest na tyle rozbudowany, że dochodzi do pomyłek na skutek zbyt dużej ilości zmiennych, nie odczuwa się potrzeby stosowania jakichś specjalnych nazw. Podobnie jest z używaniem komentarzy - dopóki wiadomo, o co chodzi, wszystko jest ok, ale wystarczy zrobić sobie dłuższą przerwę i już zmienia się podejście do sprawy stosowania tego czegoś  :D