Autor Wątek: Visual C++ 2005 Express - problem z kompilacja pod Win32  (Przeczytany 3214 razy)

Offline sapcio1

  • Użytkownik

# Luty 15, 2006, 16:31:30
witajcie!
mam do was  male pytanka...

ostatni przesiadlem sie z msvc++ 6.0 do wersji 2005 express edit.
nowy darmowy kompilator microsoftu i jest calkiem przyjemny.
jest tylko mala wada. nie mozna pisac zwyklych aplikacji pod win32.
probowalem sciagbac ze strony microsoftu jakies sdk z lib i *.h, ale zadne znich nie dzialalo...
mozecie zarzucic pelna nazwa tego sdk albo jkims linkiem... bylbym bardzo wdzieczny


bylbym bardzo wdzieczny za odpowiedzi na powyzsze pytania :)
« Ostatnia zmiana: Luty 15, 2006, 19:16:39 wysłana przez st3tc »

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline really

  • Użytkownik

# Luty 15, 2006, 16:51:41
To się nazywa Platform SDK, zawiera wszystkie liby i headery do programowania pod win32. Do ściągnięcia ze strony MS oczywiście.

BTW: czemu ten wątek nazywa się "SDK i problem z datą"?
« Ostatnia zmiana: Luty 15, 2006, 19:16:50 wysłana przez st3tc »

Offline Thorn123

  • Użytkownik

# Luty 15, 2006, 19:55:40
tu masz dokladny opis jak podpiac platforme SDK pod visual c++ http://msdn.microsoft.com/vstudio/express/visualc/usingpsdk/

Offline Fehu

  • Użytkownik

# Luty 23, 2006, 19:43:10
Mam problem otoz tez uzywam vc c++ 2005 sciagnalem i zainstalowalem sdk, zrobilem wszystko tak jak w instrukcji z linka powyzej. Wszystko dziala cacy, pisalem sobie rozne rzeczy kompilowalem i odpalalem i wszystko dzialalo. Az do momentu gdy wzialem nowy projekt, po kolejnej kompilacji nacisnalem start debugging i wyskoczyl mi komunikacik :
"Uruchomienie tej aplikacji nie powiodlo sie, poniewaz nie znalezniono MSVCR80D.dll.
Ponowne zainstalowanie aplikacji moze naprawic ten problem."
biblioteke te mam w folderach sdk ale jakby jej nie znajdowal. Jakas mala rada?
Help

Pozdrawiam

Antrykot

  • Gość
# Luty 23, 2006, 19:52:36
Pewnie coś z konfigiem, ale nie wchodząc w szczegóły wystarczy skopiować ją do windows/System32.

Offline Fehu

  • Użytkownik

# Luty 23, 2006, 20:27:34
Niestety ni pomoglo, za to dostalem drugiego errora  :o

Offline Fehu

  • Użytkownik

# Luty 24, 2006, 18:12:10
Czy moze ktos wie co moge zrobic zeby mi visual C++ dzialal normalnie?Mam taki problem ze niby program dziala do pewnego momentu a tu w pewnym momencie jak chce zaczac debugowac to wyskakuje mi blad ktory opisalem wyzej.Niestety to co mi polecono nie dziala jak widec wyzej... :( Moze jest jakis inny sposob?
"Uruchomienie tej aplikacji nie powiodlo sie, poniewaz nie znalezniono MSVCR80D.dll.
Ponowne zainstalowanie aplikacji moze naprawic ten problem."
To jest komunikat bledu.
HELP!

Offline shyha

  • Użytkownik
    • Shyha@Flickr

# Luty 25, 2006, 11:26:28
a czytałeś ten wątek:
http://forum.warsztat.gd/index.php/topic,318.0.html
?

i czy zrobiłeś to co ci podpowiada ten messagebox, który ci się pojawił? (manifest i dokumentacja)
« Ostatnia zmiana: Luty 25, 2006, 11:29:21 wysłana przez shyha »