Autor Wątek: Problem z UNITY... Prosze o pomoc.  (Przeczytany 1112 razy)

Offline anczart

  • Użytkownik

# Listopad 19, 2016, 17:08:48
Witam, otóż ostatnimi czasy unity mi wariuje... Co chwilę pojawiają się jakieś błędy odnosnie kodu. Przykład:

The namespace `global::' already contains a definition for `RCCEnterExitCar'
lub
The nested type `EmissionModule' does not exist in the type `UnityEngine.ParticleSystem'

Kazdy skrypt w projekcie niewazne jakim, czy własny skrypt czy tez jakis z internetu posiada zawsze jakis błąd... Czy ktos ma jakis pomysl jak to usunac? Nie ma skryptu bez błedu, chociaz juz kiedys pracowałem na starszej wersji na tych skryptach i wszystko smigało... Aktualnie mam unity 5.03.

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline JasonVoorhees

  • Użytkownik
    • The Immortal Life of the Son of Jay

# Listopad 19, 2016, 19:13:33
Zainstaluj najnowsze Unity.

Poza tym jeśli Twoje skrypty były pisane pod starszą wersję Unity, to może się okazać, że będziesz musiał coś ręcznie poprawić.

A co do:

Cytuj
The namespace `global::' already contains a definition for `RCCEnterExitCar'

Taki błąd może występować, jeśli gdzieś w modułach masz dwa razy definicję tego samego obiektu. Może po prostu w katalogu Assets powieliłeś folder ze skryptami i masz po 2 razy te same nazwy klas w projekcie, tylko w innych folderach.
« Ostatnia zmiana: Listopad 19, 2016, 19:19:15 wysłana przez JasonVoorhees »

Offline anczart

  • Użytkownik

# Listopad 19, 2016, 19:46:25
Zainstaluj najnowsze Unity.

Poza tym jeśli Twoje skrypty były pisane pod starszą wersję Unity, to może się okazać, że będziesz musiał coś ręcznie poprawić.

A co do:

Taki błąd może występować, jeśli gdzieś w modułach masz dwa razy definicję tego samego obiektu. Może po prostu w katalogu Assets powieliłeś folder ze skryptami i masz po 2 razy te same nazwy klas w projekcie, tylko w innych folderach.
Nowsza wersja skutkuje pojawieniem się bug reportu. Musze pracować na 5.0 niestety...

Offline laggyluk

  • Użytkownik
    • http://laggyluk.com

# Listopad 19, 2016, 20:03:46
crash z pustym projektem?

Offline jerryharpman

  • Użytkownik

  • +1
# Listopad 23, 2016, 23:52:17
The namespace `global::' already contains...

Mi taki błąd wskakiwał jak przypadkiem skopiowałem ten sam kod w dwóch skryptach.
Poszukaj czy gdzieś ci się nie powtarza jakaś klasa.
// ok, właśnie zauważyłem, że już była na to odpowiedź xD