Autor Wątek: Aplikacja nie została właściwie zainicjonana 0xc0000142 - dziwny bład  (Przeczytany 2071 razy)

Offline IgI

  • Użytkownik

# Kwiecień 28, 2014, 14:10:12
Parę dniu temu postawiłem na moim laptopie z powrotem Windowsa Vistę z płyt odzyskiwania, ponieważ potrzebowałem zbudować projekt pod Windowsem. Zainstalowałem sobie środowisko Visual Studio C++ 2010 (z którego już wcześniej korzystałem), zainstalowałem wszystkie aplikacje i przystąpiłem do dzieła. Moja aplikacja oparta jest na SFML 2.1. Projekt przygotowałem według wytycznych ze strony SFML, skompilowałem go i odpaliłem i dostaję następujący błąd:
https://www.dropbox.com/s/jn3n6i9tvxilge1/Bez%C2%A0tytu%C5%82u.jpg
Co ciekawe aplikacja odpala się normalnie i wygląda na to, że działa. Więc mam pytanie jaka może być tego przyczyna, bo niestety google mi nie pomógł, a jedyne co się dowiedziałem to, że może to być problem z jakimiś DLLkami. Jeszcze mogę dodać, że próbowałem budować aplikację w trybie Win32 i Win32 Console
w wersji static i dynamic, a także próbowałem zrobić testowy program pod SFML i ciągle to samo.

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline Xender

  • Użytkownik

# Kwiecień 28, 2014, 14:16:59
Osobliwe.

Może sprawdź, czy wersje binarek SFML (statycznych i dynamicznych, jeśli używasz obu) na pewno pasują do wersji Visuala i jego redistów. W razie czego możesz przekompilować SFML ze źródeł.

Problem jest tylko z programami korzystającymi z SFML czy ze wszystkimi?

Offline IgI

  • Użytkownik

# Kwiecień 28, 2014, 14:27:20
Wersję biblioteki mam pasującą pod Visual 2010, a sprawdziłem sobie inne programy i wszystko śmiga jak tylko nie ma SFML. Jak znajdę chwilę czasu to przekompiluje ze źródeł i zobaczę jak działa.

EDIT: Na źródłach skompilowanych z kodu to samo. Poza tym znalazłem w internecie, że problem może dotyczyć .NET frameworka, więc jak tylko wrócę do domu to zrobię reinstall.

EDIT2: Zrobiłem reinstall frameworka i przez chwilę wyglądało no to, że jest dobrze, ale jak zaisnatlowałem aktualizację do 4.5.1 to coś znów zaczęło świrować. W sumie już nie mam siły do tego, a do póki program się buduje i działa to niech tak zostanie. Przynajmniej na razie. :)
« Ostatnia zmiana: Kwiecień 29, 2014, 14:29:00 wysłana przez IgI »