Autor Wątek: VM Linux i OpenGL ES  (Przeczytany 2283 razy)

Offline _OskaR

  • Użytkownik

# Wrzesień 07, 2012, 00:32:30
Udało się komuś odpalić aplikację pod OpenGL ES 2.0 na wirtualnym linuchu?
Po włączeniu akceleracji w ustawieniach VMware, jakoś można odpalić parę zwykłych GLowych gierek, ale desktopowej grafy nie idzie zainstalować. Po odpaleniu przykładów z http://www.imgtec.com/powervr/insider/sdkdownloads/index.asp mam
Your Hardware is not capable of running OpenGL ES 1.1 emulation!Da się coś z tym zrobić, czy pozostaje jedynie postawienie systemu w normalny sposób?

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline Xenox93

  • Użytkownik

# Wrzesień 07, 2012, 13:58:57
Najlepszą i najszybszą metodą jest instalacja OS na komputerze ;) Swoją drogą musiałbyś sprawdzić inny program do wirtualizacji, być może umożliwi korzystanie z wszystkich programów napisanych w OGL :)

BTW, nigdy nie uzyskasz takiej samej ilości fps na systemie emulowanym na CPU niż na OS zainstalowanym na komputerze ;) Tak więc czy jest sens bawienia się w to? Zgadzam się z tobą jeśli uważasz, że chcesz tylko sprawdzić czy program się uruchamia, ale do codziennej obsługi, do grania itp. się nie nadaje :)

Aa... zapomniałbym najpierw zapytać. Jaką wersję OGL obsługuje twoje GPU? Bo jeśli napiszesz aplikację w mniejszej wersji OGL niż 3.3. Natomiast twoja karta graficzna, która jest zintegrowana lub nie, obsługuje tylko wersję 2.1 to nie ma sensu nawet instalować systemu :)

Offline Avaj

  • Użytkownik

# Wrzesień 07, 2012, 14:10:45
Najlepszą i najszybszą metodą jest instalacja OS na komputerze ;) Swoją drogą musiałbyś sprawdzić inny program do wirtualizacji, być może umożliwi korzystanie z wszystkich programów napisanych w OGL :)

BTW, nigdy nie uzyskasz takiej samej ilości fps na systemie emulowanym na CPU niż na OS zainstalowanym na komputerze ;) Tak więc czy jest sens bawienia się w to? Zgadzam się z tobą jeśli uważasz, że chcesz tylko sprawdzić czy program się uruchamia, ale do codziennej obsługi, do grania itp. się nie nadaje :)

Aa... zapomniałbym najpierw zapytać. Jaką wersję OGL obsługuje twoje GPU? Bo jeśli napiszesz aplikację w mniejszej wersji OGL niż 3.3. Natomiast twoja karta graficzna, która jest zintegrowana lub nie, obsługuje tylko wersję 2.1 to nie ma sensu nawet instalować systemu :)

Offline Xenox93

  • Użytkownik

# Wrzesień 07, 2012, 14:36:20
Haha... Dobre ;) Ale uważam, że nie ma się co zastawiać nad problemem, który można rozwiązać w najprostszy sposób. Nic nie pisałem, że autor niczego nie wie. Chodziło mi raczej o to, aby nie tracić czasu na taki problem, a raczej wykorzystać go do programowania lub czegoś innego. Ale dobra, już nie spamuję, hehe :D