Autor Wątek: początki z stl  (Przeczytany 733 razy)

Offline txt

  • Użytkownik

# Maj 05, 2012, 21:29:10
Witam
Właśnie zaczynam swoją pracę z biblioteką stl i mam problem.
Napisałem program i skompilowałem go w Visual C++ 2008.
Niestety wyskakuje błąd:
main.obj : error LNK2019: unresolved external symbol __imp___CrtDbgReportW referenced in function "public: __thiscall std::_Vector_const_iterator<struct vertex3f,class std::allocator<struct vertex3f> >::_Vector_const_iterator<struct vertex3f,class std::allocator<struct vertex3f> >(struct vertex3f *,class std::_Container_base_secure const *)" (??0?$_Vector_const_iterator@Uvertex3f@@V?$allocator@Uvertex3f@@@std@@@std@@QAE@PAUvertex3f@@PBV_Container_base_secure@1@@Z)Wydaje mi się, że to problem w inicjalizacji biblioteki.

Z góry dziękuję i pozdrawiam. :)
// Multikonto, ale widać poprawę, więc niech będzie (SD)
« Ostatnia zmiana: Maj 05, 2012, 21:34:54 wysłana przez ShadowDancer »

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline Bloodian

  • Użytkownik

# Maj 05, 2012, 21:36:31
1. Pomoglo by gdybys wrzucil chociaz troche kodu.
2. Sprobuj to :
http://social.msdn.microsoft.com/Forums/en-US/vcgeneral/thread/26d8934b-b62b-4496-b24a-ebfe503ec6a5/
Mi kiedys pomoglo przy podobnym errorze.

Offline ShadowDancer

  • Moderator

# Maj 05, 2012, 21:38:49
Błąd nie jest raczej z kodem, bo nie linkuje liba do debugowania.
To jest kwestia opcji projektu.

Offline txt

  • Użytkownik

# Maj 06, 2012, 10:51:47
Też sądzę, że to kwestia projektu, i że nie dołączyłem odpowiedniego .lib.

Już wszystko naprawione. Bloodian wielkie dzięki za link. On mi pomógł rozwiązać problem, który był w opcjach projektu.
« Ostatnia zmiana: Maj 06, 2012, 11:03:38 wysłana przez txt »