Autor Wątek: Problem z Visual studio 2010  (Przeczytany 4959 razy)

Offline diego997

  • Użytkownik

# Październik 21, 2011, 14:09:38
Przepraszam nie wiedziałem gdzie to napisać mam następujący problem podczas kompilacji obojetnie jakiego kodu wyskakuje mi błąd:

1>C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\Microsoft.Cpp.Win32.Targets(147,5): error MSB6006: "CL.exe" exited with code -1073741515.

Od wczoraj staram się to rozwiązać ale ręce już opadają. Chyba że ktoś wie jak zainstalować allegro 5 pod MVS 2008 Express bo z tym kompilatorem nie mam problemu

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline Asmodeusz

  • Użytkownik
    • Bogumił Wiatrowski: Blog

# Październik 21, 2011, 14:14:38
Wygląda na to, że brakuje jakiejś zależności/DLLki potrzebnej kompilatorowi. Przeinstaluj Visuala/użyj opcji Repair w "Programy i funkcje".

Offline JasonVoorhees

  • Użytkownik
    • FotoGry

# Październik 21, 2011, 14:33:32
« Ostatnia zmiana: Październik 21, 2011, 14:36:59 wysłana przez JasonVoorhees »

Offline diego997

  • Użytkownik

# Październik 21, 2011, 14:47:01
@Asmodeusz już tak robiłem tylko że usunąłem samego Visuala z Dodaj/Usuń może trzeba też wyczyścić rejestr?

@JasonVoorhees A code::Block bardzo różni się od Visuala ?

Offline Asmodeusz

  • Użytkownik
    • Bogumił Wiatrowski: Blog

# Październik 21, 2011, 14:54:13
Stwórz nowy projekt Console C/C++ i spróbuj skompilować. Jak pójdzie, to znaczy że z Visualem jest OK i trzeba szukać błędu gdzie indziej, jeśli nie, to (po kolei):
- odinstaluj Visual Studio (wszystkie wersje!)
- odinstaluj .NET Framework 4
- odinstaluj Visual 2010 Redist
- restart
- zainstaluj Visuala

Offline diego997

  • Użytkownik

# Październik 21, 2011, 14:55:56
OK tak zrobię dzięki za zainteresowanie :)

Offline JasonVoorhees

  • Użytkownik
    • FotoGry

# Październik 21, 2011, 15:03:02
@JasonVoorhees A code::Block bardzo różni się od Visuala ?
Instalacja i konfiguracja jest mniej kłopotliwa. Edytor mi się bardziej podoba (to się czuje :D ) i ogólnie program jest lżejszy.

Offline diego997

  • Użytkownik

# Październik 21, 2011, 15:08:48
Ostatni raz instaluje Visuala jak teraz ruszy będzie fajnie :), jak nie to spróbuje z Code Block

Offline diego997

  • Użytkownik

# Październik 21, 2011, 15:27:40
Nosz kur... nadal to samo, nie chce instalować nic innego jestem przyzwyczajony do visuala @Asmodeusz masz może jeszcze jakieś pomysły ?

Offline Asmodeusz

  • Użytkownik
    • Bogumił Wiatrowski: Blog

# Październik 21, 2011, 15:32:53
Nosz kur... nadal to samo, nie chce instalować nic innego jestem przyzwyczajony do visuala @Asmodeusz masz może jeszcze jakieś pomysły ?
social.msdn.com i tam pytać o pomoc, dokładnie opisać problem, podać konfigurację systemową. Jak MVC3 nie chciał mi działać na Win2003, dokładne (działające) rozwiązanie dostałem w 15 minut.

Offline diego997

  • Użytkownik

# Październik 21, 2011, 15:47:31
ok popytam dzięki

Offline MaxGarden

  • Użytkownik
    • Profil na warsztacie

# Październik 21, 2011, 15:49:00
Pierwszy link z google : KILK!
Tam jest inny kod błędu ale spróbuj, może pomoże ;].

Offline diego997

  • Użytkownik

# Październik 21, 2011, 15:59:17
Juz to wcześniej próbowałem nie pomogło ;p

Offline diego997

  • Użytkownik

# Październik 21, 2011, 16:47:10
Na tym forum piszą żebym zainstalował wirtualną maszynę i powinno ruszyć ;p Zrobić tak czy nie warto ?

Offline MaxGarden

  • Użytkownik
    • Profil na warsztacie

# Październik 21, 2011, 17:04:41
A umiesz zrobić coś samodzielnie czy o wszystko musisz się pytać ?