Autor Wątek: [SFML]Obraz się nie wyświetla  (Przeczytany 1029 razy)

Offline mar3

  • Użytkownik

# Czerwiec 03, 2011, 15:10:08
Tworzę grę Memory na PC na I gracza w SFML. Mam problem sprajt tworzony w klasie się nie wyświetla tylko biały prostokąt. Stworzyłem taki sam sprajt w main'ie z tym samym obrazkiem 1.png i się wyświetla. Tutaj znajduje się skompresowany do .rar'a cały folder projektu (visual c++ 2010 EE) wraz ze zrzutem z ekranu gry.

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline hfjh

  • Użytkownik

# Czerwiec 03, 2011, 15:17:08
Rozumiem, że nie zaglądałeś do FAQ SFMLa? ;)
« Ostatnia zmiana: Czerwiec 03, 2011, 15:31:15 wysłana przez hfjh »

Offline mar3

  • Użytkownik

# Czerwiec 03, 2011, 15:29:14
Rozumiem, że nie zaglądałeś do FAQ SFMLa? ;)
Uczyłem się z tego kursu: http://cpp0x.pl/kursy/Kurs-SFML-C++/284. A o co chodzi?
« Ostatnia zmiana: Czerwiec 03, 2011, 15:32:52 wysłana przez mar3 »

Offline hfjh

  • Użytkownik

# Czerwiec 03, 2011, 15:34:44
Chyba o nic. W FAQ jest jest taki podpunkt, ale po przejrzeniu Twojego kodu (był gdzieś pomiędzy masą nie potrzebnych plików) dochodzę do wniosku, że to inna sytuacja.


EDIT: Po bardziej dogłębnej analizie kodu: tak, przypadek FAQ to jednak Twój problem.
« Ostatnia zmiana: Czerwiec 03, 2011, 15:37:09 wysłana przez hfjh »

Offline mar3

  • Użytkownik

# Czerwiec 03, 2011, 21:00:33
poprawiona_gra_memory.rar - poprawiony projekt. Teraz widać obrazek. Czy ten kod jest dobry? Czy jeszcze coś poprawić np. zamiast obraz wysyłać przez referencje wysyłać prze wskaźnik?