Autor Wątek: Test silnika - kłopotliwy shader  (Przeczytany 9741 razy)

Offline PsichiX (ΨΧΞ)

  • Użytkownik
    • PsichiX Website

# Marzec 12, 2010, 22:49:20
Z pomocą Kuby D. doszedłem do tego, że crashe mogły być spowodowane nieoczekiwanym kasowaniem tekstury fbo, gdy nie zostało poprawnie utworzone, naprawiłem, teraz działa na moim starym testowym ati na którym też crashowało, mam nadzieję że na Waszym również już będzie śmigać :)

Link: http://psichix.com/wp-content/uploads/2010/03/XeBlurTest.zip

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline vashpan

  • Użytkownik
    • Strona

# Marzec 12, 2010, 23:24:50
Mi na drugim kompie, pod Windows 7 32bit i Radeonie HD 4650, w ogole nie startuje i sie wysypuje. Potrzebuje to jakichs bibliotek jeszcze ?

Offline PsichiX (ΨΧΞ)

  • Użytkownik
    • PsichiX Website

# Marzec 12, 2010, 23:32:11
raczej nie, ale jesli chodzi o win7 to na innym forum user podal rozwiazanie:
Cytuj
Trzeba wyłaczyć kompozycje wizualne i kompozycje pulpitu Windows'a [...] Dodatkowo musi być w trybie zgodności z XP (może z Vistą działa ale nie jestem pewien)

Offline vashpan

  • Użytkownik
    • Strona

# Marzec 12, 2010, 23:48:00
No teraz dziala ok :) Ale tez trzeba cos z tym zrobic bo przeciez to nowy silnik ;)

Offline PsichiX (ΨΧΞ)

  • Użytkownik
    • PsichiX Website

# Marzec 13, 2010, 12:32:59
@Vashpan: Pytanie, co zrobić? Bo nie mam bladego pojęcia jak mam programowo dostosować kompatybilność z win7 :/ Ma ktoś z Was może jakiś pomysł, lub wskazówki gdzie szukać? (msdn pewnie pierwszym miejscem, ale liczy się hasło kluczowe, a u nich to kuleje ;P)

Offline Asmodeusz

  • Użytkownik
    • Bogumił Wiatrowski: Blog

# Marzec 15, 2010, 00:53:50
Kiedyś w MSDN newsletterze był obszerny artykuł o problemach z kompatybilnością starych programów, uruchamianych pod Windows Vista/7. Było opisane sporo przyczyn i rozwiązań - może poszukaj za "typical compatibility issues" po artykułach?

Offline dannte

  • Użytkownik

# Marzec 15, 2010, 11:41:08
Dobra, nikt tego nie napisał to ja napiszę:
Otóż, gdy poruszam myszką z góry na dół i vice versa widać, że na pewnej poziomej linii odświeżanie ekranu działa jakoś nie tego (tak jakby mieszał poprzednią klatkę z aktualną). Myślałem, że to coś z monitorem/kartą, ale problem polega na tym, że jeśli zwiększę blura, to linia odpowiednio niżej się przesuwa, aż przy BLUR=11 problemu brak (linia przesuwa się poza dolną krawędź okna).
Popraw to.

Pozdro.

Offline PsichiX (ΨΧΞ)

  • Użytkownik
    • PsichiX Website

# Marzec 15, 2010, 12:14:00
jesli fps miales wiekszy niz 60 (jakims cudem moglo nie zadzialac vsync, a forced vsync nie wlaczalem) to sie nie dziwie ze tak miales i nie podlega to naprawie :)
przecież nie poprawia się czegoś co nie jest błędem - "this is not a bug, this is feature" :D

BTW. Rozwiazalem problem z vista i nieuruchamiajacym sie programem, dodalem pobieranie logu z GLSL i prosze osoby ktorym nie dzial test, o sprawdzenie tego i podeslanie logu silnika i pliku info jesli cos nadal nie bedzie dzialalo:

http://psichix.com/wp-content/uploads/2010/03/New-Blur-Shader-Test.zip
« Ostatnia zmiana: Marzec 15, 2010, 12:50:46 wysłana przez PsichiX »

Offline rajkonkret

  • Użytkownik
    • o mnie

# Marzec 15, 2010, 15:22:08
u mnie windows xp karta gf 9600gt działa... wyswietla 60 fps... w wolnej chwili potestuje na win7. a jak można ten silnik wykorzystać?

Offline PsichiX (ΨΧΞ)

  • Użytkownik
    • PsichiX Website

# Marzec 15, 2010, 15:47:22
Cytuj
a jak można ten silnik wykorzystać?
generalnie jest to silnik z frameworkiem typu ALL-IN-ONE, czyli wszystko czego potrzebujesz (na razie poza edytorami, które są w drodze ;P) do stworzenia gry 2D czy to 3D. Ale póki jest w wersji beta, nadal może wykazywać zachowania niestabilne, czy nie działać wszędzie tak samo :P

Offline vashpan

  • Użytkownik
    • Strona

# Marzec 15, 2010, 16:08:25
Teraz pod Win7 + Radeon 4650, dziala dobrze :)

Offline Barthap

  • Użytkownik
    • Mój blog

# Marzec 15, 2010, 17:34:45
działa poprawnie

Offline MaxGarden

  • Użytkownik
    • Profil na warsztacie

# Marzec 16, 2010, 15:36:13
daj nowy link

EDIT:
sorry działa