Autor Wątek: Eclipse 3.5 - problemy z mechanizmem instalacji modułów  (Przeczytany 675 razy)

Offline MadBonsai

  • Użytkownik
    • Ifrit

# Grudzień 11, 2009, 21:57:50
Miałem ten problem pod windą, powrócił skubianiec pod Linuxem. Uprzedzam, że googlowałem, ale wydaje się, że problem może być powodowany przez wiele rzeczy. A mój okazać się trywialny. Słabo znam specyfikę pingwina (obecnie nie korzystam z windą do kodzenia, poszukuję pomocy odnośnie Linuxa), może wystarczy "przestawić zworkę" ;)
Do tej pory dwa razy chciałem dodać coś do Eclipse.
1. Aptana Studio.
2. GWT - SDK z wtyką.
Przy znacznej części pakietów Aptany i całości GWt otrzymuję komunikat "Cannot complete the install because one or more required items could not be found."
I jestem w kropce.

Siedzę na Kubuntu Karmic. Eclipse instalowane z repo.

EDIT
Po 5 reinstalacjach i wielu kombinacjach udało mi się to rozwiązać. A już się bałem, że spędzę weekend bez programowania ;)
Problem polega na tym, że wersja 3.5 ma domyślnie pustą listę źródeł pakietów, nie ma nawet adresu repo http://dl.google.com/eclipse/plugin/3.5 - czyli instalatory wtyczek nie wiedziały skąd pobrać zależności. Wystarczy dodać powyższą ścieżkę i reszta powinna śmigać. Prawie... mi na początku nie chciało to działać, dopiero po całkowitym przeczyszczeniu i reinstalacji zaskoczyło.
« Ostatnia zmiana: Grudzień 12, 2009, 00:16:17 wysłana przez 0xCAFE »

Offline Mr. Spam

  • Miłośnik przetworów mięsnych