Autor Wątek: [SDL+MSVC++ 2008] Problem z debuggerem  (Przeczytany 854 razy)

Offline Kuza

  • Użytkownik

# Kwiecień 14, 2009, 22:59:49
Witam, przy próbie debbugowania swojego programu wyskakuje mi parę błędów typu:

'sdl.exe': Loaded 'D:\Debug\SDL.dll', Binary was not built with debug information.
Strzelam, że to jest przyczyną tego, że nie mogę odpalić debugowania w trybie: "Runtime tracking and disable optimizations".

Zaznaczam, że 'Generate Debug Info' jest zaznaczone oraz sama aplikacja jest kompilowana w trybie Debug.

Pozdrawiam.

Offline Mr. Spam

  • Miłośnik przetworów mięsnych

Offline Xion

  • Redaktor
    • xion.log

# Kwiecień 14, 2009, 23:34:31
Fakt, że SDL.dll jest w wersji bez informacji do debugowania oznacza mniej więcej tyle, że samej tej biblioteki nie możesz debugować (co zasadniczo nie powinno być potrzebne). Nie wpływa to na możliwość debugowania kodu twojego własnego programu, który z tej biblioteki korzysta.

Offline Kuza

  • Użytkownik

# Kwiecień 15, 2009, 00:28:02
Tzn. zależy mi na tym, aby podczas gdy jest włączona moja aplikacja, jednocześnie analizował co dzieje się w kodzie źródłowym. Nie wiem czy dobrze zrozumiałem Twój post, ale wygląda na to, że nici z takiego trybu debuggowania?

Pozdrawiam.

Offline Liosan

  • Redaktor

# Kwiecień 15, 2009, 00:44:25
Z tego, jak rozumiem podany przez Ciebie komunikat o błędzie (i post Xiona zdaje się to potwierdzać :)), wynika tylko, że nie będzie możliwe debugowanie kodu SDLa, natomiast Twój kod (w tym ten wykorzystujący SDL) powinien być ok.

Liosan

Offline Kuza

  • Użytkownik

# Kwiecień 15, 2009, 01:22:11
Tak, tak, składnia w kodzie się zgadza, gorzej z resztą (semantyka/logika) ;). No cóż, trudno i dzięki.

Pozdrawiam.